PS4

PS5 won’t be backward-compatible with PS3, PS2, or PS1, Ubisoft says

Sony’s next-gen PlayStation will feature some level of backward compatibility with PlayStation 4 games, but PlayStation 5 owners may not get the full 25 years of backward compatibility they may be dreaming of. According to a support FAQ on Ubisoft’s website, the PS5 will not be backward-compatible with original PlayStation, PlayStation 2, or PlayStation 3 games.

Sony had never promised backward compatibility for PlayStation, PS2, and PS3 games on PS5. But reports from July speculated about the possibility of wide-ranging backward compatibility on PS5, playable from a cloud-based game library. Those reports were based on patent filings in Japan, not something that Sony announced.

PlayStation 5 will support “the overwhelming majority” of the more than 4,000 PS4 titles released to date, Sony senior VP of platform planning and management Hideaki Nishino said in March, amid confusion about Sony’s plans. Several game developers have already pledged to support PS4 versions of their games on PS5, including CD Projekt Red’s Cyberpunk 2077 and Treyarch/Raven Software’s Call of Duty: Black Ops Cold War.

We’ve reached out to Sony for clarification on the extent of PlayStation 5’s backward compatibility support and will update when the company responds. It’s worth noting that the support FAQ entry on Ubisoft’s website is different depending on which region you’re viewing. The Australian version of the support page notes that “Backwards compatibility will be available for supported PlayStation 4 titles, but will not be possible for PlayStation 3, PlayStation 2, or PlayStation games,” while the U.S. equivalent does not mention those platforms at all.

Source: Read Full Article